Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libreoffice-still/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libreoffice-still/PKGBUILD')
-rw-r--r--extra/libreoffice-still/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/libreoffice-still/PKGBUILD b/extra/libreoffice-still/PKGBUILD
index abe13200..9d0822a1 100644
--- a/extra/libreoffice-still/PKGBUILD
+++ b/extra/libreoffice-still/PKGBUILD
@@ -1,3 +1,4 @@
+# description missing
eval "$(
declare -f build | \
sed '
@@ -6,3 +7,21 @@ eval "$(
s|--enable-ext-nlpsolver|--disable-ext-nlpsolver|
'
)"
+
+# no coin-ormp on i486 (for now, suitesparse has atomic issues)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//coin-or-mp/})
+fi
+
+# no KDE/Plasma on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//plasma-framework/})
+fi
+
+# no LTO
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-lto/--disable-lto/
+ '
+)"