Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/liborcus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/liborcus/PKGBUILD')
-rw-r--r--extra/liborcus/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/extra/liborcus/PKGBUILD b/extra/liborcus/PKGBUILD
new file mode 100644
index 00000000..31d6804c
--- /dev/null
+++ b/extra/liborcus/PKGBUILD
@@ -0,0 +1,30 @@
+# download location and packaging is a mess, fixing locally here as
+# we have to do a rebuild of libreoffice..
+source[0]="https://gitlab.com/orcus/orcus/-/archive/${pkgver}/liborcus-${pkgver}.tar.gz"
+sha256sums[0]='b2c30fb24ddadfe9bc94ac5d55782e6137ba727e90f4c9420dab5fde0d51f661'
+eval "$(
+ declare -f build | \
+ sed '
+ s/cd /cd orcus-0.17.2-8865b88c8627953c1c4f371c3a582f58f233295d/
+ /configure/ i \
+ ./autogen.sh
+ '
+)"
+
+eval "$(
+ declare -f check | \
+ sed '
+ s/cd /cd orcus-0.17.2-8865b88c8627953c1c4f371c3a582f58f233295d/
+ '
+)"
+
+eval "$(
+ declare -f package | \
+ sed '
+ s/cd /cd orcus-0.17.2-8865b88c8627953c1c4f371c3a582f58f233295d/
+ '
+)"
+
+
+# ignore tests (Python is broken)
+unset check