Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libnids/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libnids/PKGBUILD')
-rw-r--r--extra/libnids/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/libnids/PKGBUILD b/extra/libnids/PKGBUILD
new file mode 100644
index 00000000..7a510454
--- /dev/null
+++ b/extra/libnids/PKGBUILD
@@ -0,0 +1,17 @@
+# libndis defines some functions inline, so they are not in the shared library,
+# needed for instance for dsniff
+# see https://src.fedoraproject.org/cgit/rpms/libnids.git/commit/?id=ecafb692f20e0acad555f66c3cc1646997a82dae
+
+source+=('libnids-1.24-inline.patch')
+sha256sums+=('3aea2351877c2a789d753ac66f1323a3d575dead9fb04c559e221dbebdfc7e3e')
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/$pkgname-$pkgver" \
+ patch -Np1 -i "$srcdir/libnids-1.24-inline.patch"
+ '
+)"