Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libjxl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libjxl/PKGBUILD')
-rw-r--r--extra/libjxl/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/extra/libjxl/PKGBUILD b/extra/libjxl/PKGBUILD
new file mode 100644
index 00000000..29fb0241
--- /dev/null
+++ b/extra/libjxl/PKGBUILD
@@ -0,0 +1,20 @@
+if [ "${CARCH}" = "i486" ]; then
+ # Java broken on i486 temporarily
+ makedepends=(${makedepends[@]//java-environment/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-DJPEGXL_INSTALL_JARDIR='.*'//
+ '
+ )"
+
+ # break circle with gimp
+ makedepends=(${makedepends[@]//gimp/})
+fi
+
+# blacklisted on i486 and i686 as I don't really know how to switch
+# off SSE2 in this mess. It builds on i686 in a chroot on AMD64 but
+# wrongly tests positive for SSE2.
+
+# they fail in various waus
+unset check