Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libjxl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libjxl/PKGBUILD')
-rw-r--r--extra/libjxl/PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/extra/libjxl/PKGBUILD b/extra/libjxl/PKGBUILD
index 29fb0241..9785a119 100644
--- a/extra/libjxl/PKGBUILD
+++ b/extra/libjxl/PKGBUILD
@@ -12,9 +12,18 @@ if [ "${CARCH}" = "i486" ]; then
makedepends=(${makedepends[@]//gimp/})
fi
-# blacklisted on i486 and i686 as I don't really know how to switch
-# off SSE2 in this mess. It builds on i686 in a chroot on AMD64 but
-# wrongly tests positive for SSE2.
+# Disable SSE2
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f build | \
+ sed 's/-DCMAKE_BUILD_TYPE/-DSJPEG_ENABLE_SIMD=OFF -DCMAKE_BUILD_TYPE/'
+ )"
+
+ eval "$(
+ declare -f prepare | \
+ sed '$ d' | sed '$ a sed -i s/HWY_SSSE3/HWY_SSSE3\\|HWY_SSE2\\|HWY_SSE4/ "${srcdir}/libjxl/CMakeLists.txt";}'
+ )"
+fi
-# they fail in various waus
+# they fail in various ways
unset check