Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libjpeg-turbo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libjpeg-turbo/PKGBUILD')
-rw-r--r--extra/libjpeg-turbo/PKGBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/extra/libjpeg-turbo/PKGBUILD b/extra/libjpeg-turbo/PKGBUILD
index df1c23d0..ad9cdef4 100644
--- a/extra/libjpeg-turbo/PKGBUILD
+++ b/extra/libjpeg-turbo/PKGBUILD
@@ -3,7 +3,18 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- s/cmake/cmake -DWITH_SIMD=0/
+ /local cmake_options/ a \
+ cmake_options+=(-DWITH_SIMD=0)
+ '
+ )"
+
+ # Java broken on i486 temporarily
+ makedepends=(${makedepends[@]//java-environment>11/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /local cmake_options/ a \
+ cmake_options+=(-DWITH_JAVA=0)
'
)"
fi