Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libinput/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libinput/PKGBUILD')
-rw-r--r--extra/libinput/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/extra/libinput/PKGBUILD b/extra/libinput/PKGBUILD
new file mode 100644
index 00000000..7d2e83a9
--- /dev/null
+++ b/extra/libinput/PKGBUILD
@@ -0,0 +1,12 @@
+# used by debug gui
+# fails to rebuild currently on i486
+# /usr/bin/ld: warning: libicui18n.so.69, needed by /usr/lib//libtracker-sparql-3.0.
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Ddebug-gui=false /g
+ '
+ )"
+ makedepends+=(icu69)
+fi