Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libfido2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libfido2/PKGBUILD')
-rw-r--r--extra/libfido2/PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/extra/libfido2/PKGBUILD b/extra/libfido2/PKGBUILD
index 77ebd65c..ac4f24c6 100644
--- a/extra/libfido2/PKGBUILD
+++ b/extra/libfido2/PKGBUILD
@@ -1,7 +1,15 @@
-# no -Werror
+# somehow -Wno-dev disappeard and we have full -Werror again
+source+=(libfido2-1.14.0-no-werror.patch)
+sha512sums+=(3bc56d2926d5cfc8838d23775254e0d01f68c79a95b94f6787e72b8402c4617cc2a4abf75be6c573e619fd6f94574bdeb2b79f162354230372e935f6e20da709)
+b2sums+=(8a50d473ca2eda54ceaeaae0ce85af1109119949ac5db354b02b726507547f4a9c1f38f9e7d5c598b328ccf3276224a0e5374222dafeaf76e7ebc9aeb891d801)
+
eval "$(
- declare -f build \
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
| sed '
- /\bcmake\b/ i sed -i "/Werror/d" CMakeLists.txt
+ $i cd "${srcdir}/${pkgbase}-${pkgver}" \
+ patch -Np1 -i "$srcdir/libfido2-1.14.0-no-werror.patch"
'
)"