Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libavif
diff options
context:
space:
mode:
Diffstat (limited to 'extra/libavif')
-rw-r--r--extra/libavif/PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/extra/libavif/PKGBUILD b/extra/libavif/PKGBUILD
index 10c53c42..47e6ff77 100644
--- a/extra/libavif/PKGBUILD
+++ b/extra/libavif/PKGBUILD
@@ -9,7 +9,7 @@ eval "$(
# on i486 we ignore rav1e for now (needs rust)
if [ "$CARCH" = 'i486' ]; then
- depends=(${depends[@]//rav1e/})
+ depends=(${depends[@]//librav1e.so/})
eval "$(
declare -f build | \
sed '
@@ -18,3 +18,11 @@ if [ "$CARCH" = 'i486' ]; then
)"
fi
+# no Haskell
+makedepends=(${makedepends[@]//pandoc-cli/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/-DAVIF_BUILD_MAN_PAGES=ON/-DAVIF_BUILD_MAN_PAGES=OFF/
+ '
+)"