Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/julia/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/julia/PKGBUILD')
-rw-r--r--extra/julia/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/extra/julia/PKGBUILD b/extra/julia/PKGBUILD
new file mode 100644
index 00000000..a00df5b2
--- /dev/null
+++ b/extra/julia/PKGBUILD
@@ -0,0 +1,31 @@
+eval "$(
+ declare -f build | \
+ sed '
+ /.*make.*$_buildopts/ i \
+ _buildopts="${_buildopts/MARCH=x86-64/MARCH=pentium4}" \
+ '
+)"
+
+eval "$(
+ declare -f package | \
+ sed '
+ /.*make.*$_buildopts/ i \
+ _buildopts="${_buildopts/MARCH=x86-64/MARCH=pentium4}" \
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ /^\s*make / i export CFLAGS+=" -march=pentium4" \
+ export CXXFLAGS+=" -march=pentium4"
+ '
+)"
+
+eval "$(
+ declare -f package | \
+ sed '
+ /^\s*make / i export CFLAGS+=" -march=pentium4" \
+ export CXXFLAGS+=" -march=pentium4"
+ '
+)"