Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/gtk3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/gtk3/PKGBUILD')
-rw-r--r--extra/gtk3/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/extra/gtk3/PKGBUILD b/extra/gtk3/PKGBUILD
new file mode 100644
index 00000000..c0a54d18
--- /dev/null
+++ b/extra/gtk3/PKGBUILD
@@ -0,0 +1,21 @@
+# on i486 we need libglvnd for libepoxy (mesa doesn't depend on it?)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends+=(libglvnd)
+fi
+
+# no tracker3 on i486, doesn't build at the moment due to Vala introspection,
+# documentation tool issues, etc.
+depends=(${depends[@]//tracker3/})
+depends_i686+=(tracker3)
+depends_pentium4=("${depends_i686[@]}")
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-D tracker3=true/-D tracker3=false/
+ '
+ )"
+fi
+
+# atk bridge is missing, fast hack to work around atk-bridge/atk conflicts
+depends+=('at-spi2-core')