Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/gstreamer/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/gstreamer/PKGBUILD')
-rw-r--r--extra/gstreamer/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/extra/gstreamer/PKGBUILD b/extra/gstreamer/PKGBUILD
index 7442af2c..e37c1a44 100644
--- a/extra/gstreamer/PKGBUILD
+++ b/extra/gstreamer/PKGBUILD
@@ -9,6 +9,18 @@ eval "$(
# svt-hevc is blacklisted
makedepends=(${makedepends[@]//svt-hevc/})
+# onnxruntime won't build currently (and probably ever but who knows)
+makedepends=(${makedepends[@]//onnxruntime/})
+pkgname=(${pkgname[@]//gst-plugin-onnx/})
+
+eval "$(
+ declare -f build | \
+ sed '
+ /local meson_options.*/ a \
+ meson_options+=(-Dgst-plugins-bad:onnx=disabled)
+ '
+)"
+
eval "$(
declare -f build | \
sed '