Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/exa/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/exa/PKGBUILD')
-rw-r--r--extra/exa/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/extra/exa/PKGBUILD b/extra/exa/PKGBUILD
new file mode 100644
index 00000000..914a7177
--- /dev/null
+++ b/extra/exa/PKGBUILD
@@ -0,0 +1,25 @@
+# pandoc is mainly broken currently (FS32#180)
+makedepends=(${makedepends[@]//pandoc/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/pandoc/#pandoc/
+ '
+)"
+eval "$(
+ declare -f package | \
+ sed '
+ /exa.1/d
+ /exa_colors.5/d
+ '
+)"
+
+# CARCH pentium4 makes compilation fail
+if [ "$CARCH" = 'pentium4' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/--target "$CARCH-unknown-linux-gnu"/--target "i686-unknown-linux-gnu"/
+ '
+ )"
+fi