Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/clisp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/clisp/PKGBUILD')
-rw-r--r--extra/clisp/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/extra/clisp/PKGBUILD b/extra/clisp/PKGBUILD
new file mode 100644
index 00000000..16aecfee
--- /dev/null
+++ b/extra/clisp/PKGBUILD
@@ -0,0 +1,18 @@
+# no LTO
+sed -i "
+ /^options=/ a options+=('!lto')
+" PKGBUILD
+eval "$(
+ declare -f build | \
+ sed '
+ s/-ffat-lto-objects//
+ '
+)"
+
+# alignment of function (from VoidLinux)
+eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|CFLAGS+=" -falign-functions=4" ./configure|
+ '
+)"