Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/boost/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/boost/PKGBUILD')
-rw-r--r--extra/boost/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/boost/PKGBUILD b/extra/boost/PKGBUILD
new file mode 100644
index 00000000..12fb68df
--- /dev/null
+++ b/extra/boost/PKGBUILD
@@ -0,0 +1,14 @@
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-ffat-lto-objects//g
+ '
+ )"
+fi