Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/blender/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/blender/PKGBUILD')
-rw-r--r--extra/blender/PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/extra/blender/PKGBUILD b/extra/blender/PKGBUILD
new file mode 100644
index 00000000..97c987b0
--- /dev/null
+++ b/extra/blender/PKGBUILD
@@ -0,0 +1,59 @@
+makedepends=(
+ ${makedepends[@]/cuda/}
+)
+depends=(
+ ${depends[@]/openimagedenoise/}
+)
+pkgdesc+=", without CUDA support"
+eval "$(
+ declare -f build \
+ | sed '
+ /^\s*cmake / s/;$/ -DWITH_CYCLES_CUDA_BINARIES=OFF -DWITH_CYCLES_DEVICE_CUDA=OFF -DWITH_RAYOPTIMIZATION=OFF;/
+ '
+)"
+source_i686+=('no-sse2.patch')
+sha512sums_i686+=('87da2bedb90af6dee559ef9d1eb83262ba75fb412aba83dcb2b88fe9c0740ff75ad336331033fec7a14ad6ecc3dd70f8f4742f147594e8dc530197dd51922c01')
+if [ "${CARCH}" = 'i686' ]; then
+ eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -Np1 -i "$srcdir"/no-sse2.patch
+ '
+ )"
+fi
+
+# no Nvidia Optix
+pkgdesc+=", without Optix support"
+eval "$(
+ declare -f build \
+ | sed '
+ /^\s*cmake / s/;$/ -DWITH_CYCLES_DEVICE_OPTIX=OFF/
+ '
+)"
+
+# FS32#182: opensubdiv/openexr/openvdb currently fails to rebuild
+depends=(
+ ${depends[@]/opensubdiv/}
+)
+depends=(
+ ${depends[@]/openexr/}
+)
+depends=(
+ ${depends[@]/openvdb/}
+)
+
+# float_t is a long double on 32-bit, but it's a primitive in all cases anyway
+# (seems to be in a part of the blendkernel on i686 only..)
+source+=('blender-idprop_create-static-assert-float.patch')
+sha512sums+=('36b98ec7e53402909a9e531c30b444b1afc22cc597c5bb3393c73862929dcc6275b00a53de6171a81af3c8804d233359d2e797886d0b776e7a9b29b23ce24e3b')
+eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -Np1 -i "$srcdir"/blender-idprop_create-static-assert-float.patch
+ '
+)"
+
+# fails happily to build
+depends=(
+ ${depends[@]/openpgl/}
+)