Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/aubio
diff options
context:
space:
mode:
Diffstat (limited to 'extra/aubio')
-rw-r--r--extra/aubio/PKGBUILD19
-rw-r--r--extra/aubio/assert-almost.patch27
2 files changed, 46 insertions, 0 deletions
diff --git a/extra/aubio/PKGBUILD b/extra/aubio/PKGBUILD
new file mode 100644
index 00000000..578b458a
--- /dev/null
+++ b/extra/aubio/PKGBUILD
@@ -0,0 +1,19 @@
+eval "$(
+ declare -f prepare | \
+ sed '
+ /^{/ a patch -d "${pkgbase}-${pkgver}" -p1 -i "${srcdir}/assert-almost.patch"
+ '
+)"
+source+=(assert-almost.patch)
+sha512sums+=('3a946aaf305ee93ad70ca3b26529fdd58822c9bd177b5a00ace99426b1ba50672d24331d13b6b172a0f8d01ed23feea478b6a15f379d6affa796eb6c2aaadeb2')
+b2sums+=('44d2e64fd38d9f57c2e281e3a656f4bf66ccc9c4434a75c216c7605df25f4383256d57d9cacf3ea46b2eaaa8de52ef460d82bf4500d46591caf0a1a26bd25b2a')
+
+# CARCH -> pentium4 bug
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f check | \
+ sed '
+ s/$CARCH/i686/
+ '
+ )"
+fi
diff --git a/extra/aubio/assert-almost.patch b/extra/aubio/assert-almost.patch
new file mode 100644
index 00000000..9951636e
--- /dev/null
+++ b/extra/aubio/assert-almost.patch
@@ -0,0 +1,27 @@
+--- a/python/tests/test_hztomel.py 2019-03-07 15:05:44.804472410 +0100
++++ b/python/tests/test_hztomel.py 2019-03-07 15:05:44.804472410 +0100
+@@ -17,10 +17,10 @@
+ assert_equal(hztomel(0.), 0.)
+ assert_almost_equal(hztomel(400. / 3.), 2., decimal=5)
+ assert_almost_equal(hztomel(1000. / 3), 5.)
+- assert_equal(hztomel(200.), 3.)
++ assert_almost_equal(hztomel(200.), 3.)
+ assert_almost_equal(hztomel(1000.), 15)
+- assert_almost_equal(hztomel(6400), 42)
+- assert_almost_equal(hztomel(40960), 69)
++ assert_almost_equal(hztomel(6400), 42, decimal=5)
++ assert_almost_equal(hztomel(40960), 69, decimal=5)
+
+ for m in np.linspace(0, 1000, 100):
+ assert_almost_equal(hztomel(meltohz(m)) - m, 0, decimal=3)
+--- a/python/tests/test_hztomel.py 2019-03-07 15:16:06.396709250 +0100
++++ b/python/tests/test_hztomel.py 2019-03-07 15:16:06.396709250 +0100
+@@ -28,7 +28,7 @@
+ def test_meltohz(self):
+ assert_equal(meltohz(0.), 0.)
+ assert_almost_equal(meltohz(2), 400. / 3., decimal=4)
+- assert_equal(meltohz(3.), 200.)
++ assert_almost_equal(meltohz(3.), 200., decimal=5)
+ assert_almost_equal(meltohz(5), 1000. / 3., decimal=4)
+ assert_almost_equal(meltohz(15), 1000., decimal=4)
+ assert_almost_equal(meltohz(42), 6400., decimal=2)