Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/krb5/PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/core/krb5/PKGBUILD b/core/krb5/PKGBUILD
index 4fd0a819..2f2447df 100644
--- a/core/krb5/PKGBUILD
+++ b/core/krb5/PKGBUILD
@@ -1,10 +1,20 @@
# temporarily disable libverto in order to break build cycle
depends=(${depends[@]//libverto.so/})
depends=(${depends[@]//libverto-module-base/})
-
eval "$(
declare -f build | \
sed '
s|--with-system-verto||
'
)"
+
+# do not install development artifacts of libverto (conflicts
+# with libverto above and causes more cycles)
+eval "$(
+ declare -f package | \
+ sed '
+ $ i \
+ rm -f "${pkgdir}/usr/include/{verto,-module}.h" \
+ rm -f "${pkgdir}/usr/lib/libverto.so"
+ '
+)"