Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-06-16 07:38:05 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-06-16 07:38:05 +0200
commit4f4669077048acac6fc2a55e3d510f05c44c124a (patch)
tree03a2b504e152a6c1d9f0640ed443ec8e3dd74a50 /core
parentb1d413f6235c0480fb34371ce10f627371ec5524 (diff)
core/krb5: more cycle breaking with libverto developmenmt artifacts
Diffstat (limited to 'core')
-rw-r--r--core/krb5/PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/core/krb5/PKGBUILD b/core/krb5/PKGBUILD
index 4fd0a819..2f2447df 100644
--- a/core/krb5/PKGBUILD
+++ b/core/krb5/PKGBUILD
@@ -1,10 +1,20 @@
# temporarily disable libverto in order to break build cycle
depends=(${depends[@]//libverto.so/})
depends=(${depends[@]//libverto-module-base/})
-
eval "$(
declare -f build | \
sed '
s|--with-system-verto||
'
)"
+
+# do not install development artifacts of libverto (conflicts
+# with libverto above and causes more cycles)
+eval "$(
+ declare -f package | \
+ sed '
+ $ i \
+ rm -f "${pkgdir}/usr/include/{verto,-module}.h" \
+ rm -f "${pkgdir}/usr/lib/libverto.so"
+ '
+)"