Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/binutils/PKGBUILD2
-rw-r--r--core/coreutils/PKGBUILD5
-rw-r--r--core/coreutils/coreutils-8.30-uname-i486.patch12
-rw-r--r--core/coreutils/coreutils-9.5-uname-i486.patch12
-rw-r--r--core/libtool/PKGBUILD3
-rw-r--r--core/openssl/PKGBUILD4
6 files changed, 19 insertions, 19 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index f4694854..627e520a 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -49,7 +49,7 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- s/--enable-pgo-build=.*/--disable-pgo-build/
+ s/--enable-pgo-build=lto/--disable-pgo-build/
s/--enable-lto/--disable-lto/
s/--enable-gold/--disable-gold/
'
diff --git a/core/coreutils/PKGBUILD b/core/coreutils/PKGBUILD
index f4b69568..5385a852 100644
--- a/core/coreutils/PKGBUILD
+++ b/core/coreutils/PKGBUILD
@@ -1,8 +1,8 @@
# 486-specific
if [ "${CARCH}" = "i486" ]; then
# make uname return i486 instead of i686 when used with setarch
- source+=('coreutils-8.30-uname-i486.patch')
- sha256sums+=('4e3971d7c5f6363d2d2ceeea23958ec6db1d6e5d2c7fc20bc5d6d6bfa7290ad0')
+ source+=('coreutils-9.5-uname-i486.patch')
+ sha256sums+=('9c8b9c88a2f737808ef43dca4c7ea03c638930e33f3c01e7c407ec6f9f67f218')
fi
# FS#66506: temporarily ignore test-login failure
@@ -12,3 +12,4 @@ eval "$(
s/make check/make check || true/
'
)"
+
diff --git a/core/coreutils/coreutils-8.30-uname-i486.patch b/core/coreutils/coreutils-8.30-uname-i486.patch
deleted file mode 100644
index f7872693..00000000
--- a/core/coreutils/coreutils-8.30-uname-i486.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN coreutils-8.30/src/uname.c coreutils-8.30-uname-patch-i486/src/uname.c
---- coreutils-8.30/src/uname.c 2018-05-14 06:20:24.000000000 +0200
-+++ coreutils-8.30-uname-patch-i486/src/uname.c 2019-01-28 21:12:09.151041534 +0100
-@@ -285,6 +285,8 @@
-
- if (uname (&name) == -1)
- die (EXIT_FAILURE, errno, _("cannot get system name"));
-+
-+ strcpy(name.machine, "i486");
-
- if (toprint & PRINT_KERNEL_NAME)
- print_element (name.sysname);
diff --git a/core/coreutils/coreutils-9.5-uname-i486.patch b/core/coreutils/coreutils-9.5-uname-i486.patch
new file mode 100644
index 00000000..7250be30
--- /dev/null
+++ b/core/coreutils/coreutils-9.5-uname-i486.patch
@@ -0,0 +1,12 @@
+diff -rauN coreutils-9.5/src/uname.c coreutils-9.5-uname-i486-patch/src/uname.c
+--- coreutils-9.5/src/uname.c 2024-01-01 14:27:23.000000000 +0100
++++ coreutils-9.5-uname-i486-patch/src/uname.c 2024-04-26 08:25:24.914671684 +0200
+@@ -298,6 +298,8 @@
+
+ if (uname (&name) == -1)
+ error (EXIT_FAILURE, errno, _("cannot get system name"));
++
++ strcpy(name.machine, "i486");
+
+ if (toprint & PRINT_KERNEL_NAME)
+ print_element_env (name.sysname, "UNAME_SYSNAME");
diff --git a/core/libtool/PKGBUILD b/core/libtool/PKGBUILD
deleted file mode 100644
index eb241c98..00000000
--- a/core/libtool/PKGBUILD
+++ /dev/null
@@ -1,3 +0,0 @@
-# temporary fix for FS#65995
-source[3]='https://sources.debian.org/data/main/libt/libtool/2.4.6-14/debian/patches/no_hostname.patch'
-sha256sums[3]='693aabb24a6e7ce21fe0b5d14394e19edcb8476663b5afa4463f9fa0df24d946'
diff --git a/core/openssl/PKGBUILD b/core/openssl/PKGBUILD
index 03c17f77..0de77e9c 100644
--- a/core/openssl/PKGBUILD
+++ b/core/openssl/PKGBUILD
@@ -13,7 +13,8 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- s@enable-ktls@enable-ktls 386 no-threads@
+ s@enable-ktls@enable-ktls 386@
+ s@make@make LDFLAGS='-latomic@'
'
)"
fi
@@ -35,3 +36,4 @@ eval "$(
s/make.*test/make test || true/
'
)"
+