Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/curl/PKGBUILD5
-rw-r--r--core/libarchive/PKGBUILD5
-rw-r--r--core/pacman/PKGBUILD8
-rw-r--r--core/pacman/pacman-trailing-slash-muon.patch22
-rw-r--r--core/xz/PKGBUILD12
5 files changed, 52 insertions, 0 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index 6d7d6522..70a13a74 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,3 +1,8 @@
# Valgrind seems broken for now
unset check
unset checkdepends
+
+# temporary, we still build a version with rtmpdump though upstream now
+# has no dependency on anymore?
+depends+=(rtmpdump)
+
diff --git a/core/libarchive/PKGBUILD b/core/libarchive/PKGBUILD
index 56ede898..86ca2216 100644
--- a/core/libarchive/PKGBUILD
+++ b/core/libarchive/PKGBUILD
@@ -10,3 +10,8 @@ eval "$(
s/configure/configure --without-xml2 /
'
)"
+
+# temporary, we still build a version with libb2 though upstream now
+# has no dependency on libb2 anymore?
+depends+=(libb2)
+
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 2efb1da1..6bb4e067 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -73,6 +73,9 @@ fi
makedepends=(${makedepends[@]//meson/})
makedepends+=(muon-meson)
+source+=(pacman-trailing-slash-muon.patch)
+sha256sums+=(f295ff9967d38117bb5a29237716abb997197c69d8d2eeb449db49b85582be02)
+
eval "$(
declare -f build | \
sed '
@@ -100,3 +103,8 @@ eval "$(
# fails happilly at the moment, going full risk now and installing it anyway..
unset check
unset checkdepends
+
+# overwrite wrong checksum on rust.conf? does't work in buildmaster, works
+# in chroot?! Disabling again..
+#sha256sums[5]='6fe03e6ea3f69d99d59a48847a8ae97c2160fca847c7aedf7b89d05e4aa9386d'
+
diff --git a/core/pacman/pacman-trailing-slash-muon.patch b/core/pacman/pacman-trailing-slash-muon.patch
new file mode 100644
index 00000000..4b3c393f
--- /dev/null
+++ b/core/pacman/pacman-trailing-slash-muon.patch
@@ -0,0 +1,22 @@
+diff -rauN pacman-orig/meson.build pacman-trailing-slash-muon-patch/meson.build
+--- pacman-orig/meson.build 2025-03-20 17:46:34.979754357 +0100
++++ pacman-trailing-slash-muon-patch/meson.build 2025-03-20 17:47:38.620712716 +0100
+@@ -68,13 +68,13 @@
+ conf.set_quoted('SCRIPTLET_SHELL', get_option('scriptlet-shell'))
+ conf.set_quoted('LDCONFIG', LDCONFIG)
+ conf.set_quoted('LIB_VERSION', libalpm_version)
+-conf.set_quoted('SYSHOOKDIR', join_paths(DATAROOTDIR, 'libalpm/hooks/'))
++conf.set_quoted('SYSHOOKDIR', join_paths(DATAROOTDIR, 'libalpm/hooks/') + '/')
+ conf.set_quoted('CONFFILE', join_paths(SYSCONFDIR, 'pacman.conf'))
+-conf.set_quoted('DBPATH', join_paths(LOCALSTATEDIR, 'lib/pacman/'))
+-conf.set_quoted('GPGDIR', join_paths(SYSCONFDIR, 'pacman.d/gnupg/'))
++conf.set_quoted('DBPATH', join_paths(LOCALSTATEDIR, 'lib/pacman/') + '/')
++conf.set_quoted('GPGDIR', join_paths(SYSCONFDIR, 'pacman.d/gnupg/') + '/')
+ conf.set_quoted('LOGFILE', join_paths(LOCALSTATEDIR, 'log/pacman.log'))
+-conf.set_quoted('CACHEDIR', join_paths(LOCALSTATEDIR, 'cache/pacman/pkg/'))
+-conf.set_quoted('HOOKDIR', join_paths(SYSCONFDIR, 'pacman.d/hooks/'))
++conf.set_quoted('CACHEDIR', join_paths(LOCALSTATEDIR, 'cache/pacman/pkg/') +'/')
++conf.set_quoted('HOOKDIR', join_paths(SYSCONFDIR, 'pacman.d/hooks/') + '/')
+ conf.set_quoted('ROOTDIR', ROOTDIR)
+
+ libintl = dependency('', required: false)
diff --git a/core/xz/PKGBUILD b/core/xz/PKGBUILD
new file mode 100644
index 00000000..dce2ecd7
--- /dev/null
+++ b/core/xz/PKGBUILD
@@ -0,0 +1,12 @@
+makedepends=(${makedepends[@]//doxygen/})
+eval "$(
+ declare -f build | \
+ sed '
+ /configure/s/--enable-doxygen/--disable-doxygen/
+ '
+)"
+
+if [ "${CARCH}" = "i486" ]; then
+ sha256sums[0]='SKIP'
+ sha512sums[0]='SKIP'
+fi