Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'core/systemd')
-rw-r--r--core/systemd/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index 6b71579b..ccec11a5 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -1,3 +1,13 @@
+# replace SBAT data
+eval "$(
+ declare -f build | \
+ sed '
+ s/-Dsbat-distro='"'"'arch'"'"'/-Dsbat-distro='"'"'arch32'"'"'/g
+ s/-Dsbat-distro-summary='"'"'Arch Linux'"'"'/-Dsbat-distro-summary='"'"'Arch Linux 32'"'"'/g
+ s|-Dsbat-distro-url="[^"]*"|-Dsbat-distro-url="https://archlinux32.org/packages/core/${CARCH}/${pkgname}"|g
+ '
+)"
+
# some tests run into timeouts
eval "$(
declare -f check | \