Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/pinentry/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/pinentry/PKGBUILD')
-rw-r--r--core/pinentry/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/core/pinentry/PKGBUILD b/core/pinentry/PKGBUILD
index 9c1f0644..a36a140d 100644
--- a/core/pinentry/PKGBUILD
+++ b/core/pinentry/PKGBUILD
@@ -1,8 +1,15 @@
+# no GUI stuff on i486
+makedepends=(${makedepends[@]//gtk2/})
+makedepends=(${makedepends[@]//qt5-base/})
+makedepends_i686+=(gtk2 qt5-base)
+
+# no gcr on i486
+makedepends=(${makedepends[@]//gcr/})
+makedepends_i686+=(gcr)
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# no GUI stuff
- makedepends=(${makedepends[@]//gtk2/})
- makedepends=(${makedepends[@]//qt5-base/})
eval "$(
declare -f build | \
sed '
@@ -11,7 +18,4 @@ if [ "${CARCH}" = "i486" ]; then
s/--enable-pinentry-qt/--disable-pinentry-qt/
'
)"
-
- # no gcr
- makedepends=(${makedepends[@]//gcr/})
fi