Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/pinentry/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/pinentry/PKGBUILD')
-rw-r--r--core/pinentry/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/core/pinentry/PKGBUILD b/core/pinentry/PKGBUILD
index fb6dfc37..bb3c9176 100644
--- a/core/pinentry/PKGBUILD
+++ b/core/pinentry/PKGBUILD
@@ -12,3 +12,16 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
fi
+
+# disable qt6 and wayland on i486
+if [ "${CARCH}" = "i486" ]; then
+ makedepends=(${makedepends[@]//qt6-base/})
+ makedepends=(${makedepends[@]//kwayland5/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-pinentry-qt/--disable-pinentry-qt/
+ '
+ )"
+fi
+