Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/pacman
diff options
context:
space:
mode:
Diffstat (limited to 'core/pacman')
-rw-r--r--core/pacman/PKGBUILD28
-rw-r--r--core/pacman/makepkg.conf24
-rw-r--r--core/pacman/pacman.conf5
3 files changed, 43 insertions, 14 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 27cbdbb5..e5966c06 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -4,11 +4,11 @@ depends+=(archlinux32-keyring)
# fail if upstream changes makepkg.conf or pacman.conf
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '072020e34f2c55b94a9a486829a7eadab0a830ddb4d8e759b0c4e6cf1bde73a6' ]; then
- sha256sums[${i}]='2ad58ba534fed9d728d273c7b5920a495c15cfb58b5c3864bfa023a939abc5d0'
+ if [ "${sha256sums[${i}]}" = '2465d495cb275dce434eb3bfe4d293a223e301b968c14861aea42bc7c60404ef' ]; then
+ sha256sums[${i}]='82e963060a02c9a04cf5296bb4c5e732d3c3d0666d221ddaf2b3367989b9d894'
fi
- if [ "${sha256sums[${i}]}" = '606e55f06c297d2b508bc4438890b229a1abaa68b0374a2d7f94c8e7be6792d7' ]; then
- sha256sums[${i}]='fa05e6f8a83f09fc347988a8ad9dce6fad50d542b2d77fc07fd1b604309990be'
+ if [ "${sha256sums[${i}]}" = '656c4d4cb8cb12adbf178fc8cb2fd25f8c285d6572bbdbb24d865d00e0d5a85a' ]; then
+ sha256sums[${i}]='663cbfe0643ff78c1eeb38d59046707da49bde6ab8226fbc5844457a985cb5bc'
fi
done
@@ -28,7 +28,7 @@ source+=('replace-i686-by-pentium4-when-architecture-is-auto.patch')
sha256sums+=('6a7906bd28a57cbcff58d856ffefbbb9096a163aaff79913b4fac69d75d0028a')
# not supported on i486 -fcf-protection
-# LTO currently no availavle on i486
+# LTO currently no available on i486
if [ "${CARCH}" = "i486" ]; then
eval "$(
{
@@ -41,3 +41,21 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
fi
+
+# If this still applies, it only does for i486:
+if [ "${CARCH}" = "i486" ]; then
+# broken Python/asciidoc
+ eval "$(
+ declare -f build | \
+ sed '
+ /meson/s/-Ddoc=enabled/-Ddoc=disabled/
+ '
+ )"
+fi
+
+# gettext is linked against old ICU verison on i486, use ICU 72 stub
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=(icu72)
+fi
+
+sha256sums[0]='SKIP'
diff --git a/core/pacman/makepkg.conf b/core/pacman/makepkg.conf
index 12bd0a97..69c05355 100644
--- a/core/pacman/makepkg.conf
+++ b/core/pacman/makepkg.conf
@@ -1,4 +1,6 @@
#!/hint/bash
+# shellcheck disable=2034
+
#
# /etc/makepkg.conf
#
@@ -23,7 +25,7 @@ DLAGENTS=('file::/usr/bin/curl -qgC - -o %o %u'
#-- The package required by makepkg to download VCS sources
# Format: 'protocol::package'
-VCSCLIENTS=('bzr::bzr'
+VCSCLIENTS=('bzr::breezy'
'fossil::fossil'
'git::git'
'hg::mercurial'
@@ -39,18 +41,20 @@ CHOST="i686-pc-linux-gnu"
#-- Compiler and Linker Flags
#CPPFLAGS=""
CFLAGS="-march=i686 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
- -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
- -fstack-clash-protection -fcf-protection"
+ -Wp,-D_FORTIFY_SOURCE=3 -Wformat -Werror=format-security \
+ -fstack-clash-protection -fcf-protection \
+ -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer"
CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
-LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
+LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now \
+ -Wl,-z,pack-relative-relocs"
LTOFLAGS="-flto=auto"
-#RUSTFLAGS="-C opt-level=2"
+RUSTFLAGS="-Cforce-frame-pointers=yes"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
#-- Debugging flags
DEBUG_CFLAGS="-g"
DEBUG_CXXFLAGS="$DEBUG_CFLAGS"
-#DEBUG_RUSTFLAGS="-C debuginfo=2"
+DEBUG_RUSTFLAGS="-C debuginfo=2"
#########################################################################
# BUILD ENVIRONMENT
@@ -79,7 +83,7 @@ BUILDENV=(!distcc color !ccache check !sign)
# These are default values for the options=() settings
#########################################################################
#
-# Makepkg defaults: OPTIONS=(!strip docs libtool staticlibs emptydirs !zipman !purge !debug !lto)
+# Makepkg defaults: OPTIONS=(!strip docs libtool staticlibs emptydirs !zipman !purge !debug !lto !autodeps)
# A negated option will do the opposite of the comments below.
#
#-- strip: Strip symbols from binaries/libraries
@@ -91,8 +95,9 @@ BUILDENV=(!distcc color !ccache check !sign)
#-- purge: Remove files specified by PURGE_TARGETS
#-- debug: Add debugging flags as specified in DEBUG_* variables
#-- lto: Add compile flags for building with link time optimization
+#-- autodeps: Automatically add depends/provides
#
-OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug !lto)
+OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge debug lto)
#-- File integrity checks to use. Valid: md5, sha1, sha224, sha256, sha384, sha512, b2
INTEGRITY_CHECK=(sha256)
@@ -110,6 +115,8 @@ DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
#-- Directory to store source code in for debug packages
DBGSRCDIR="/usr/src/debug"
+#-- Prefix and directories for library autodeps
+LIB_DIRS=('lib:usr/lib')
#########################################################################
# PACKAGE OUTPUT
@@ -157,3 +164,4 @@ SRCEXT='.src.tar.gz'
#
#-- Command used to run pacman as root, instead of trying sudo and su
#PACMAN_AUTH=()
+# vim: set ft=sh ts=2 sw=2 et:
diff --git a/core/pacman/pacman.conf b/core/pacman/pacman.conf
index ef347ade..75ba5b82 100644
--- a/core/pacman/pacman.conf
+++ b/core/pacman/pacman.conf
@@ -70,12 +70,15 @@ LocalFileSigLevel = Optional
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.
-#[testing]
+#[core-testing]
#Include = /etc/pacman.d/mirrorlist
[core]
Include = /etc/pacman.d/mirrorlist
+#[extra-testing]
+#Include = /etc/pacman.d/mirrorlist
+
[extra]
Include = /etc/pacman.d/mirrorlist