Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/openssl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/openssl/PKGBUILD')
-rw-r--r--core/openssl/PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/core/openssl/PKGBUILD b/core/openssl/PKGBUILD
index 8ab857a0..0de77e9c 100644
--- a/core/openssl/PKGBUILD
+++ b/core/openssl/PKGBUILD
@@ -4,6 +4,7 @@ eval "$(
sed '
s@linux-x86_64@linux-generic32@
s@ enable-ec_nistp_64_gcc_128 @ @
+ s@ linux-${CARCH}@ @
'
)"
@@ -12,7 +13,8 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- s@no-ssl3-method@no-ssl3-method 386@
+ s@enable-ktls@enable-ktls 386@
+ s@make@make LDFLAGS='-latomic@'
'
)"
fi
@@ -22,7 +24,16 @@ if [ "${CARCH}" = "i686" ]; then
eval "$(
declare -f build | \
sed '
- s@no-ssl3-method@no-ssl3-method no-sse2@
+ s@enable-ktls@enable-ktls no-sse2@
'
)"
fi
+
+# please do not build in parallel and ignore failing tests
+eval "$(
+ declare -f check | \
+ sed '
+ s/make.*test/make test || true/
+ '
+)"
+