Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/linux/PKGBUILD')
-rw-r--r--core/linux/PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 6eea3bd4..cbe8ed7c 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -34,11 +34,19 @@ eval "$(
)"
_get_gcc_version_from_config() {
- sed '
- s/^CONFIG_CC_VERSION_TEXT="gcc (GCC) \([0-9.]\+\)"$/\1/
- t
- d
- ' "$srcdir/$_srcname/.config"
+ if [ -z "$srcdir" ]; then
+ gcc --version \
+ | sed '
+ s@^.* @@
+ 1!d
+ '
+ else
+ sed '
+ s/^CONFIG_CC_VERSION_TEXT="gcc (GCC) \([0-9.]\+\)"$/\1/
+ t
+ d
+ ' "$srcdir/$_srcname/.config"
+ fi
}
# use our tarballer instead of cloning from git