Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/linux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/linux/PKGBUILD')
-rw-r--r--core/linux/PKGBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index 15534cfd..7ee56472 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,16 +1,13 @@
-# upstream git revision: f39eaea64451349803de0db05a1cf0a236a6b29b
+# Don't bother with sha256sums, use blake2 only
+unset sha256sums
source_pentium4=('config.pentium4')
source_i686=('config.i686')
source_i486=('config.i486')
-# fail if upstream's .config changes
-for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'c8b3fbb7664801bebc2d2d1fdf624524865a7817d0021c55c98523cb58dee201' ]; then
- sha256sums_pentium4=('67d0dff17091496a7f18e93008df5345ee7c2f1732c3fcfdedb41f45c3bd11d3')
- sha256sums_i686=('78a77ca3c0851c74c28adb66b21ea65b0f144351c00da116281c3d08abe0ec43')
- sha256sums_i486=('2fe21e0f93c833043b402a59abe092825c823a15bb29351bf8a3ea6530f0a5a9')
- fi
-done
+b2sums_pentium4=('5aa4f0a095965ae47ace60e90f2e098cd5967a7ba47e2d7fcb8953e126e964797ef0caccc4df151f649346e76595eab63c44f04fb57fc81cb9c5e631f3fa600a')
+b2sums_i686=('f2fad336fa6f90c36c6adfc5aa2cba3ac0fad370ab1ce3b98378808dbcc66e76eec9f441e7d315a10d31fabea3d7f1575d475a80e31496489e6d72a94f75bca9')
+b2sums_i486=('a7aa7e8319c623575e14bb8497f580e0d56030abc68dd8d3662aef62d087aa8c50dcc1f6ba7cfdbf8bfe1c42a4a56e5cdd4503de314957cbabfe8cc7acebe4fa')
+
# copy architecture specific config file, not default 'config'
eval "$(
@@ -22,9 +19,8 @@ eval "$(
# patch architecture when copying the kernel Makefile
eval "$(
- declare -f package_linux-headers | \
+ declare -f package_${pkgbase}-headers | \
sed '
- \,/tools/objtool" ,d
\,arch/x86/Makefile, {
a \
install -t "${builddir}/arch/x86" -m644 arch/x86/Makefile_32.cpu
@@ -117,7 +113,16 @@ done
# avoid using zstd compression in ultra mode (exhausts virtual memory)
source+=('no-ultra-zstd.patch')
-sha256sums+=('d32270be5fd9c3e3ba50f3aef33f6cfcb85be0c8216f03b777287cc621fdff28')
+b2sums+=('165ab9dd8cedeaae5327accc1581c19cf0be55f923b03feb889cad3351b74c7c4cd3d3c206938e5152bfe1d947513dea8f630f8f5544099ec13d16d254725c40')
+
+# objtool doesn't exist because we don't have STACK_VALIDATION
+# and resolve_btfids doesn't exist because we disable BTF due to pahole running out of memory
+eval "$(
+ declare -f package_${pkgbase}-headers | \
+ sed '/objtool/d' | \
+ sed '/resolve_btfids/d' | \
+ sed 's@tools/bpf/bpftool/vmlinux.h@@'
+)"
# temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
pkgname=(
@@ -126,11 +131,12 @@ pkgname=(
grep -v '^\$pkgbase-docs'
)
)
+
+# Also avoid building/running bpftool
eval "$(
declare -f build | \
- sed '
- s/\bhtmldocs\b//
- '
+ sed '/htmldocs/d' | \
+ sed '/bpftool/d'
)"
makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
makedepends=(${makedepends[@]//python-sphinx<6.0.0/})