Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/libarchive/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/libarchive/PKGBUILD')
-rw-r--r--core/libarchive/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/core/libarchive/PKGBUILD b/core/libarchive/PKGBUILD
index b155a0bf..7d0a99db 100644
--- a/core/libarchive/PKGBUILD
+++ b/core/libarchive/PKGBUILD
@@ -1,8 +1,13 @@
-# temporarily, see FS#63765
+# temporarily for glibc 2.36, see FS#75533
+source+=(0003-no-sys_mount-linux_fs-includes.patch)
+sha256sums+=('cdb370df255245de557f0e6b1f780798a954771833d56602633b67db8cacce53')
eval "$(
- declare -f check | \
- sed '
- s/make check/make check || true/
- '
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd "${pkgname}-${pkgver}"\n}\n'
+ } \
+ | sed '
+ $ i patch -Np1 < ../0003-no-sys_mount-linux_fs-includes.patch
+ '
)"