Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/glibc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/glibc/PKGBUILD')
-rw-r--r--core/glibc/PKGBUILD72
1 files changed, 37 insertions, 35 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index e5cf18d7..c8cb5e40 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -30,25 +30,16 @@ eval "$(
makedepends=(${makedepends[@]//gd/})
makedepends_i686+=('gd')
-if [ "${CARCH}" = "i486" ]; then
-
- # disable testing for now, we run out of memory
- eval "$(
- declare -f check | \
- sed '
- /make -O check/d
- '
- )"
-
- # disable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet/--disable-cet/
- '
- )"
-
-fi
+# patching fails, tests are disabled lower anyway completely
+#if [ "${CARCH}" = "i486" ]; then
+# # disable testing for now, we run out of memory
+# eval "$(
+# declare -f check | \
+# sed '
+# /make -O check/d
+# '
+# )"
+#fi
# pentium4 specific
@@ -102,30 +93,41 @@ eval "$(
'
)"
+# TODO: redo if we get again hen-and-egg-problems
+
# have to rebuild twice because generate localdef called in build uses wrong
# ABI resulting in:
# "locale/localedef: /usr/lib/libc.so.6: version `GLIBC_ABI_DT_RELR' not found (required by locale/localedef"
# do not regenerate it and install the one from the chroot
-eval "$(
- declare -f build | \
- sed '
- /localedef/d
- '
-)"
-eval "$(
- declare -f package_glibc | \
- sed '
- s|"$srcdir/C.UTF-8"|/usr/lib/locale/C.UTF-8|g
- '
-)"
+#eval "$(
+# declare -f build | \
+# sed '
+# /localedef/d
+# '
+#)"
+#eval "$(
+# declare -f package_glibc | \
+# sed '
+# s|"${srcdir}"/C.UTF-8|/usr/lib/locale/C.UTF-8|g
+# '
+#)"
# readd locale generation removed by lib32 sed-fu above in build!
+# breaks again on glibc library mismatches
+#eval "$(
+# declare -f build | \
+# sed '
+# $ i locale/localedef -c -f ../glibc/localedata/charmaps/UTF-8 -i ../glibc/localedata/locales/C ../C.UTF-8/
+# '
+#)"
+
+# ignoring tests for now (they hang, checked manually, see skip_tests above)
+unset check
+
+# disable CET (Control Flow instructions endbr32/enbr64)
eval "$(
declare -f build | \
sed '
- $ i locale/localedef -c -f ../glibc/localedata/charmaps/UTF-8 -i ../glibc/localedata/locales/C ../C.UTF-8/
+ s/--enable-cet/--disable-cet/
'
)"
-
-# ignoring tests for now (they hang, checked manually, see skip_tests above)
-unset check