Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/gcc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/gcc/PKGBUILD')
-rw-r--r--core/gcc/PKGBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/core/gcc/PKGBUILD b/core/gcc/PKGBUILD
index 423fa566..ca003988 100644
--- a/core/gcc/PKGBUILD
+++ b/core/gcc/PKGBUILD
@@ -88,24 +88,6 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
- # disable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet=auto/--disable-cet/
- '
- )"
-
-else
-
- # force enable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet=auto/--enable-cet/
- '
- )"
-
fi
makedepends=(${makedepends[@]//lib32-glibc/})
@@ -128,3 +110,16 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
fi
+
+# testing on 486 VMs takes too long and runs in virtual memory exhaustion
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
+
+# disable CET on all subarchitectures (Control Flow instructions endbr32/enbr64)
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-cet=auto/--disable-cet/
+ '
+)"