Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/dbus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/dbus/PKGBUILD')
-rw-r--r--core/dbus/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/core/dbus/PKGBUILD b/core/dbus/PKGBUILD
index c9efd760..4123575d 100644
--- a/core/dbus/PKGBUILD
+++ b/core/dbus/PKGBUILD
@@ -1,4 +1,11 @@
-# no graphviz generated graphs in documentation on i486
-makedepends=(${makedepends[@]//graphviz/})
-makedepends_i686+=(graphviz)
-makedepends_pentium4=("${makedepends_i686[@]}")
+# Disable documentation on i486, it just fails everywhere
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-xml-docs/--disable-xml-docs/
+ s/--enable-doxygen-docs/--disable-doxygen-docs/
+ s/--enable-ducktype-docs/--disable-ducktype-docs/
+ '
+ )"
+fi