Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/sarg/no-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/sarg/no-werror.patch')
-rw-r--r--community/sarg/no-werror.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/community/sarg/no-werror.patch b/community/sarg/no-werror.patch
deleted file mode 100644
index 7d04349b..00000000
--- a/community/sarg/no-werror.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index aac6933..aa784ea 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -71,18 +71,6 @@ IF(HAVE_WEXTRA)
- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Wextra -Wno-unused-parameter")
- ENDIF(HAVE_WEXTRA)
-
--CHECK_C_COMPILER_FLAG("-Werror=implicit-function-declaration" HAVE_WERROR_IMPLICIT_FUNCTION)
--IF(HAVE_WERROR_IMPLICIT_FUNCTION)
-- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
-- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=implicit-function-declaration")
--ENDIF(HAVE_WERROR_IMPLICIT_FUNCTION)
--
--CHECK_C_COMPILER_FLAG("-Werror=format" HAVE_WERROR_FORMAT)
--IF(HAVE_WERROR_FORMAT)
-- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
-- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=format")
--ENDIF(HAVE_WERROR_FORMAT)
--
- # Required header files
- CHECK_INCLUDE_FILE(stdio.h HAVE_STDIO_H)
- CHECK_INCLUDE_FILE(stdlib.h HAVE_STDLIB_H)