Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/python-tqdm
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-tqdm')
-rw-r--r--community/python-tqdm/PKGBUILD11
-rw-r--r--community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch12
2 files changed, 0 insertions, 23 deletions
diff --git a/community/python-tqdm/PKGBUILD b/community/python-tqdm/PKGBUILD
deleted file mode 100644
index b7329924..00000000
--- a/community/python-tqdm/PKGBUILD
+++ /dev/null
@@ -1,11 +0,0 @@
-# https://github.com/tqdm/tqdm/issues/538
-
-source+=('tqdm-4.22.0-sleep-test-workaround.patch')
-sha512sums+=('ac09e7578ad380f55f9371a067061bd1f23be6a799ec82c3abf2471d7d780bd435b423d0ab1f989cf7039b467d5adfa38e324cb887b0b27f52218fa3753956fa')
-
-eval "$(
- declare -f prepare | \
- sed '
- /cp/ i pushd ${srcdir}/tqdm-$pkgver && patch -Np1 -i "${srcdir}"/tqdm-4.22.0-sleep-test-workaround.patch && popd
- '
-)"
diff --git a/community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch b/community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch
deleted file mode 100644
index ac9caae3..00000000
--- a/community/python-tqdm/tqdm-4.22.0-sleep-test-workaround.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN tqdm-4.22.0/tqdm/tests/tests_synchronisation.py tqdm-4.22.0-sleep-test-workaround-patch/tqdm/tests/tests_synchronisation.py
---- tqdm-4.22.0/tqdm/tests/tests_synchronisation.py 2018-04-12 01:27:25.000000000 +0200
-+++ tqdm-4.22.0-sleep-test-workaround-patch/tqdm/tests/tests_synchronisation.py 2018-05-03 08:42:28.204036417 +0200
-@@ -155,7 +155,7 @@
- timeend = timer.time()
- while not (t1.monitor.woken >= timeend and t1.miniters == 1):
- timer.sleep(1)
-- sleep(0.000001)
-+ sleep(0.001)
- assert t1.miniters == 1 # check that monitor corrected miniters
- assert t2.miniters == 500 # check that t2 was not adjusted
-