Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/julia
diff options
context:
space:
mode:
Diffstat (limited to 'community/julia')
-rw-r--r--community/julia/PKGBUILD28
1 files changed, 21 insertions, 7 deletions
diff --git a/community/julia/PKGBUILD b/community/julia/PKGBUILD
index e8de39ab..a00df5b2 100644
--- a/community/julia/PKGBUILD
+++ b/community/julia/PKGBUILD
@@ -1,17 +1,31 @@
eval "$(
declare -f build | \
sed '
- /^\s*make / i CFLAGS+=" -march=pentium4" \
- CXXFLAGS+=" -march=pentium4"
- /MARCH="/ s/"x86-64"/"pentium4"/
+ /.*make.*$_buildopts/ i \
+ _buildopts="${_buildopts/MARCH=x86-64/MARCH=pentium4}" \
'
)"
eval "$(
- declare -f package_julia | \
+ declare -f package | \
sed '
- /^\s*make / i CFLAGS+=" -march=pentium4" \
- CXXFLAGS+=" -march=pentium4"
- /MARCH="/ s/"x86-64"/"pentium4"/
+ /.*make.*$_buildopts/ i \
+ _buildopts="${_buildopts/MARCH=x86-64/MARCH=pentium4}" \
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ /^\s*make / i export CFLAGS+=" -march=pentium4" \
+ export CXXFLAGS+=" -march=pentium4"
+ '
+)"
+
+eval "$(
+ declare -f package | \
+ sed '
+ /^\s*make / i export CFLAGS+=" -march=pentium4" \
+ export CXXFLAGS+=" -march=pentium4"
'
)"