Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-build-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/python-build-bootstrap/PKGBUILD')
-rw-r--r--build-support/python-build-bootstrap/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/build-support/python-build-bootstrap/PKGBUILD b/build-support/python-build-bootstrap/PKGBUILD
new file mode 100644
index 00000000..ec3630c4
--- /dev/null
+++ b/build-support/python-build-bootstrap/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+
+_pkgname=build
+pkgname=python-$_pkgname-bootstrap
+pkgver=0.10.0
+pkgrel=4
+pkgdesc='A simple, correct PEP 517 build frontend'
+arch=('any')
+url='https://github.com/pypa/build'
+license=('MIT')
+makedepends=('git' 'python-pip-bootstrap')
+checkdepends=('python-pytest' 'python-pytest-mock' 'python-pytest-rerunfailures' 'python-filelock' 'python-setuptools' 'python-toml' 'python-wheel')
+source=("git+$url#tag=$pkgver?signed")
+validpgpkeys=('3DCE51D60930EBA47858BA4146F633CBB0EB4BF2') # Filipe Laíns (FFY00) <lains@archlinux.org>
+sha512sums=('SKIP')
+
+build() {
+ cd $_pkgname
+
+ # we install build, installer with pip to break the cycle
+ pip install build
+ pip install installer
+ pip install flit_core
+
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+package() {
+ cd $_pkgname
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}