Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/python-bootstrap/PKGBUILD')
-rw-r--r--build-support/python-bootstrap/PKGBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/build-support/python-bootstrap/PKGBUILD b/build-support/python-bootstrap/PKGBUILD
new file mode 100644
index 00000000..8f71ada5
--- /dev/null
+++ b/build-support/python-bootstrap/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+
+pkgname=python-bootstrap
+pkgver=3.11
+pkgrel=1
+pkgdesc="Python Bootstrap"
+arch=('any')
+license=('PSF')
+url="https://gitlab.archlinux.org/archlinux/python-bootstrap"
+depends=('python')
+makedepends=('git')
+provides=('python-build' 'python-flit' 'python-flit-core' 'python-installer''python-setuptools' 'python-wheel' 'python-tomli')
+source=("git+https://gitlab.archlinux.org/archlinux/python-bootstrap/#branch=$pkgver" 'pep517.patch')
+sha512sums=('SKIP' '24b7105c1f2537ed14a97dfc43002f66bdb3bf70b4d7512ae13d43cd752b30f7c87f945310601aedecba721f17ebd20a1e61ef7be3591f276e2336e4c5807e45')
+
+export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git submodule init; git submodule update
+ cd external/build
+ git checkout cd06da25481b9a610f846fa60cb67b5a5fa9a051
+ cd ../..
+ cd external/flit
+ git remote remove origin
+ git remote add origin https://github.com/pypa/flit
+ git checkout f5704ea31f0fcc579b8518ea85d641651cba4f71
+ cd ../..
+ cd external/installer
+ git checkout e9c3b3b052d39c3030c0f792ed4e0311b7468329
+ cd ../..
+ cd external/setuptools
+ git checkout 2ab03c77d7d06845c1d76ce870cbc77cfce129ba
+ cd ../..
+ cd external/wheel
+ git checkout 814c2efe8e40051039c5a6de6945e04ecdd162ee
+ cd ../..
+ git submodule add https://github.com/pypa/pyproject-hooks external/pyproject-hooks
+ patch -Np1 -i "${srcdir}/pep517.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python -m bootstrap.build
+}
+
+wheels=(
+build-0.10.0-py3-none-any.whl
+flit_core-3.8.0-py3-none-any.whl
+installer-0.6.0-py3-none-any.whl
+pyproject_hooks-1.0.0-py3-none-any.whl
+setuptools-67.0.0.post20230512-py3-none-any.whl
+tomli-2.0.1-py3-none-any.whl
+wheel-0.38.4-py3-none-any.whl
+)
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ for wheel in "${wheels[@]}"; do
+ python -m bootstrap.install --destdir="$pkgdir" "dist/$wheel"
+ done
+}