Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/python-bootstrap/PKGBUILD')
-rw-r--r--build-support/python-bootstrap/PKGBUILD155
1 files changed, 95 insertions, 60 deletions
diff --git a/build-support/python-bootstrap/PKGBUILD b/build-support/python-bootstrap/PKGBUILD
index 6949646a..77705858 100644
--- a/build-support/python-bootstrap/PKGBUILD
+++ b/build-support/python-bootstrap/PKGBUILD
@@ -1,74 +1,109 @@
-# Maintainer: Angel Velasquez <angvp@archlinux.org>
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+# Maintainer
-pkgname=python-bootstrap
-pkgver=3.11
+pkgbase=python-bootstrap
+pkgname=(python-{build,flit-core,installer,packaging,pyproject-hooks,setuptools,wheel})
+pkgver=1
pkgrel=1
-pkgdesc="Python Bootstrap"
-arch=('any')
-license=('PSF')
+arch=(any)
+license=('custom')
+makedepends=(python git)
url="https://gitlab.archlinux.org/archlinux/python-bootstrap"
-depends=('python')
-makedepends=('git')
-provides=('python-build' 'python-flit' 'python-flit-core' 'python-installer''python-setuptools' 'python-wheel' 'python-tomli')
-source=("git+https://gitlab.archlinux.org/archlinux/python-bootstrap/#branch=$pkgver"
-'pep517.patch' 'add-packaging.patch')
-sha512sums=('SKIP'
-'24b7105c1f2537ed14a97dfc43002f66bdb3bf70b4d7512ae13d43cd752b30f7c87f945310601aedecba721f17ebd20a1e61ef7be3591f276e2336e4c5807e45'
-'0f514fc30fc62981633b6cf60ead7e128cf611e7c25b4d9a5fcdad57d507b4dd65ed43c0d69f0061f9a582c78cab6dd3370d79851d39335b3e69289b75d6bfeb'
+source=(
+ "${pkgbase}::git+https://gitlab.archlinux.org/archlinux/python-bootstrap.git#branch=python-3.12"
+ "${pkgbase}-build::git+https://github.com/pypa/build.git"
+ "${pkgbase}-flit::git+https://github.com/takluyver/flit.git"
+ "${pkgbase}-installer::git+https://github.com/pypa/installer.git"
+ "${pkgbase}-wheel::git+https://github.com/pypa/wheel.git"
+ "${pkgbase}-packaging::git+https://github.com/pypa/packaging"
+ "${pkgbase}-pyproject-hooks::git+https://github.com/pypa/pyproject-hooks"
+ "${pkgbase}-setuptools::git+https://github.com/pypa/setuptools.git"
)
-
-export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "${srcdir}/${pkgname}"
- git submodule init; git submodule update
- cd external/build
- git checkout cd06da25481b9a610f846fa60cb67b5a5fa9a051
- cd ../..
- cd external/flit
- git remote remove origin
- git remote add origin https://github.com/pypa/flit
- git checkout f5704ea31f0fcc579b8518ea85d641651cba4f71
- cd ../..
- cd external/installer
- git checkout e9c3b3b052d39c3030c0f792ed4e0311b7468329
- cd ../..
- cd external/setuptools
- git checkout 2ab03c77d7d06845c1d76ce870cbc77cfce129ba
- cd ../..
- cd external/wheel
- git checkout 814c2efe8e40051039c5a6de6945e04ecdd162ee
- cd ../..
- git submodule add https://github.com/pypa/pyproject-hooks external/pyproject-hooks
- patch -Np1 -i "${srcdir}/pep517.patch"
- git submodule add https://github.com/pypa/packaging external/packaging
- cd external/packaging
- git checkout d563917280d65a6ce2e622bd3d07438e1ee259f3
- cd ../..
- patch -Np1 -i "${srcdir}/add-packaging.patch"
+ cd python-bootstrap
+ git submodule init
+
+ git config submodule."external/build".url "${srcdir}/${pkgbase}"-build
+ git config submodule."external/flit".url "${srcdir}/${pkgbase}"-flit
+ git config submodule."external/installer".url "${srcdir}/${pkgbase}"-installer
+ git config submodule."external/wheel".url "${srcdir}/${pkgbase}"-wheel
+ git config submodule."external/packaging".url "${srcdir}/${pkgbase}"-packaging
+ git config submodule."external/pyproject-hooks".url "${srcdir}/${pkgbase}"-pyproject-hooks
+ git config submodule."external/setuptools".url "${srcdir}/${pkgbase}"-setuptools
+
+ git -c protocol.file.allow=always submodule update
+ git submodule update --init --recursive
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd python-bootstrap
python -m bootstrap.build
}
-wheels=(
-build-0.10.0-py3-none-any.whl
-flit_core-3.8.0-py3-none-any.whl
-installer-0.6.0-py3-none-any.whl
-pyproject_hooks-1.0.0-py3-none-any.whl
-setuptools-67.0.0.post20230512-py3-none-any.whl
-tomli-2.0.1-py3-none-any.whl
-wheel-0.38.4-py3-none-any.whl
-packaging-23.1-py3-none-any.whl
-)
+package_python-build() {
+ pkgdesc="A simple, correct PEP 517 build frontend"
+ depends=(
+ python
+ python-packaging
+ python-pyproject-hooks
+ )
+
+ cd python-bootstrap
+ python -m bootstrap.install dist/build-*-py3-none-any.whl -d "$pkgdir"
+}
+
+package_python-installer() {
+ pkgdesc="Low-level library for installing a Python package from a wheel distribution"
+ depends=(python)
+
+ cd python-bootstrap
+ python -m bootstrap.install dist/installer-*-py3-none-any.whl -d "$pkgdir"
+}
+
+package_python-flit-core() {
+ pkgdesc="Simplified packaging of Python modules (core backend)"
+ depends=(python)
+
+ cd python-bootstrap
+ python -m bootstrap.install dist/flit_core-*-py3-none-any.whl -d "$pkgdir"
+}
+
+package_python-wheel() {
+ pkgdesc="A built-package format for Python"
+ depends=(python)
+
+ cd python-bootstrap
+ python -m bootstrap.install dist/wheel-*-py3-none-any.whl -d "$pkgdir"
+}
+
+package_python-packaging() {
+ pkgdesc="Core utilities for Python packages"
+ depends=(python)
+
+ cd python-bootstrap
+ python -m bootstrap.install dist/packaging-*-py3-none-any.whl -d "$pkgdir"
+}
+
+package_python-pyproject-hooks() {
+ pkgdesc="A low-level library for calling build-backends in pyproject.toml-based project"
+ depends=(python)
+
+ cd python-bootstrap
+ python -m bootstrap.install dist/pyproject_hooks-*-py3-none-any.whl -d "$pkgdir"
+}
+
+package_python-setuptools() {
+ pkgdesc="Setuptools (bootstrapped version)"
+ depends=(python)
-package() {
- cd "${srcdir}/${pkgname}"
- for wheel in "${wheels[@]}"; do
- python -m bootstrap.install --destdir="$pkgdir" "dist/$wheel"
- done
+ cd python-bootstrap
+ python -m bootstrap.install dist/setuptools-*-py3-none-any.whl -d "$pkgdir"
}