Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/gdmd-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/gdmd-git/PKGBUILD')
-rw-r--r--build-support/gdmd-git/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/build-support/gdmd-git/PKGBUILD b/build-support/gdmd-git/PKGBUILD
new file mode 100644
index 00000000..653ec498
--- /dev/null
+++ b/build-support/gdmd-git/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Vladimir Panteleev <arch-pkg at thecybershadow.net>
+# https://aur.archlinux.org/packages/gdmd-git
+
+pkgname=gdmd-git
+pkgver=r31.1a4bcb2
+pkgrel=1
+pkgdesc="DMD-like wrapper for GDC"
+arch=('any')
+url="https://github.com/D-Programming-GDC/gdmd"
+license=('GPL')
+provides=('gdmd')
+conflicts=('gdmd')
+depends=('perl' 'gcc-d')
+makedepends=('git')
+source=("git+https://github.com/D-Programming-GDC/GDMD.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/GDMD"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/GDMD"
+ mkdir -p "$pkgdir"/usr/{bin,share/man/man1}
+ make install prefix=/usr DESTDIR="$pkgdir"
+}