Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/electron2/PKGBUILD16
-rw-r--r--community/electron2/allow-i686.patch14
2 files changed, 0 insertions, 30 deletions
diff --git a/community/electron2/PKGBUILD b/community/electron2/PKGBUILD
deleted file mode 100644
index 3446fe23..00000000
--- a/community/electron2/PKGBUILD
+++ /dev/null
@@ -1,16 +0,0 @@
-source+=('allow-i686.patch')
-sha512sums+=('bce6716f88c0ed7acc72f90ef62f7c4a28b88e98d7fc8dcb6abf545eb6ab7de11e06191618490ed83e7b38b08489063357682ebb909dc952e21cb6dd7b6ddb38')
-
-eval "$(
- declare -f prepare | \
- sed '
- 3 a patch -Np1 -i "${srcdir}"/allow-i686.patch
- /^}$/ i \
- find "${srcdir}" \\( '"-name '*.a' -o -name '*.o'"' \\) -delete
- '
- declare -f build | \
- sed '
- s,^\s*script/bootstrap.py ,\0--target_arch=ia32 ,
- s/-t x64/-t ia32/g
- '
-)"
diff --git a/community/electron2/allow-i686.patch b/community/electron2/allow-i686.patch
deleted file mode 100644
index 154ab9bc..00000000
--- a/community/electron2/allow-i686.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/script/update.py
-+++ b/script/update.py
-@@ -15,11 +15,6 @@ SOURCE_ROOT = os.path.abspath(os.path.dirname(os.path.dirname(__file__)))
-
- def main():
- os.chdir(SOURCE_ROOT)
--
-- if PLATFORM != 'win32' and platform.architecture()[0] != '64bit':
-- print 'Electron is required to be built on a 64bit machine'
-- return 1
--
- update_external_binaries()
- return update_gyp()
-