Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/python-jaraco.text/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/python-jaraco.text/PKGBUILD b/community/python-jaraco.text/PKGBUILD
new file mode 100644
index 00000000..29e02c8a
--- /dev/null
+++ b/community/python-jaraco.text/PKGBUILD
@@ -0,0 +1,18 @@
+# temporary to build python-build with python-bootstrap (breaking cycles)
+makedepends=(${makedepends[@]//python-build/})
+makedepends=(${makedepends[@]//python-installer/})
+makedepends=(${makedepends[@]//python-wheel/})
+makedepends+=('python-bootstrap')
+depends=(${depends[@]//python-jaraco.functools/})
+depends=(${depends[@]//python-jaraco.context/})
+depends=(${depends[@]//python-jaraco.context/})
+depends=(${depends[@]//python-autocommand/})
+depends=(${depends[@]//python-inflect/})
+unset checkdepends
+unset check
+eval "$(
+ declare -f build | \
+ sed '
+ s/python -m build --wheel --no-isolation/python -m build --wheel --no-isolation -x/g
+ '
+)"