Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/pacman/PKGBUILD13
1 files changed, 1 insertions, 12 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index e7e5974b..27cbdbb5 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -23,21 +23,10 @@ if [ ! "${CARCH}" = "i686" ]; then
)"
fi
-# patch pacman for automatic architecture detection
+# patch pacman for automatic architecture detection (applied in wildcard patch above)
source+=('replace-i686-by-pentium4-when-architecture-is-auto.patch')
sha256sums+=('6a7906bd28a57cbcff58d856ffefbbb9096a163aaff79913b4fac69d75d0028a')
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/$pkgname-$pkgver" \
- patch -p1 -i ../replace-i686-by-pentium4-when-architecture-is-auto.patch
- '
-)"
-
# not supported on i486 -fcf-protection
# LTO currently no availavle on i486
if [ "${CARCH}" = "i486" ]; then