Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/ruby-rake-compiler/PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index 6e572d80..95e1e7ee 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -1,13 +1,14 @@
-# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
-depends=(ruby-bootstrap)
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'rust'
+makedepends=(ruby-bootstrap)
# no documentation during bootstrapping
makedepends=(${makedepends[@]//ruby-rdoc/})
-# create /opt/ruby-xxx/bin
+# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
'
)"