Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/meson/PKGBUILD3
-rw-r--r--extra/python-build/PKGBUILD25
-rw-r--r--extra/python-flit-core/PKGBUILD6
-rw-r--r--extra/python-flit/PKGBUILD10
-rw-r--r--extra/python-installer/PKGBUILD8
-rw-r--r--extra/python-jaraco.context/PKGBUILD18
-rw-r--r--extra/python-jaraco.functools/PKGBUILD13
-rw-r--r--extra/python-jaraco.text/PKGBUILD18
-rw-r--r--extra/python-more-itertools/PKGBUILD8
-rw-r--r--extra/python-ordered-set/PKGBUILD7
-rw-r--r--extra/python-packaging/PKGBUILD7
-rw-r--r--extra/python-pefile/PKGBUILD2
-rw-r--r--extra/python-pyproject-hooks/PKGBUILD8
-rw-r--r--extra/python-setuptools-scm/PKGBUILD9
-rw-r--r--extra/python-tomli/PKGBUILD7
-rw-r--r--extra/python-wheel/PKGBUILD9
16 files changed, 0 insertions, 158 deletions
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index c1e8f364..b3fe95a2 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -25,6 +25,3 @@ for ((i=0; i<${#b2sums[@]}; i++)); do
b2sums[${i}]='9f134aabfce63ed31e579724cdfb6de0a8a4c27998a11caa796c7660842904d646688e6f106026f9a68f4c67ea7a61d7d86c762e4688db0f383268a85880edf8'
fi
done
-
-# bootstrap
-makedepends=('python-bootstrap')
diff --git a/extra/python-build/PKGBUILD b/extra/python-build/PKGBUILD
deleted file mode 100644
index 125d6731..00000000
--- a/extra/python-build/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# disable documentation (needs sphinx, sphinx-furo)
-# python-sphinx-furo needs npm, which is broken on archlinux32
-# most likely since years..
-makedepends=(${makedepends[@]//python-sphinx-furo/})
-makedepends=(${makedepends[@]//python-sphinx-argparse-cli/})
-makedepends=(${makedepends[@]//python-sphinx-autodoc-typehints/})
-makedepends=(${makedepends[@]//python-sphinx/})
-eval "$(
- declare -f build | \
- sed '
- /.*sphinx-build.*/d
- '
- declare -f package | \
- sed '
- /.*\/share\/doc.*/d
- '
-)"
-
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-flit-core/PKGBUILD b/extra/python-flit-core/PKGBUILD
deleted file mode 100644
index b8a84aa2..00000000
--- a/extra/python-flit-core/PKGBUILD
+++ /dev/null
@@ -1,6 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-flit/PKGBUILD b/extra/python-flit/PKGBUILD
deleted file mode 100644
index 602d5f1f..00000000
--- a/extra/python-flit/PKGBUILD
+++ /dev/null
@@ -1,10 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-depends=(${depends[@]//python-docutils/})
-depends=(${depends[@]//python-flit-core/})
-depends=(${depends[@]//python-requests/})
-depends=(${depends[@]//python-tomli-w/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-installer/PKGBUILD b/extra/python-installer/PKGBUILD
index 6dd1a147..e5c1ec0f 100644
--- a/extra/python-installer/PKGBUILD
+++ b/extra/python-installer/PKGBUILD
@@ -13,11 +13,3 @@ eval "$(
/docs\/build\/html/d
'
)"
-
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-jaraco.context/PKGBUILD b/extra/python-jaraco.context/PKGBUILD
deleted file mode 100644
index b0d7bd85..00000000
--- a/extra/python-jaraco.context/PKGBUILD
+++ /dev/null
@@ -1,18 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-wheel/})
-makedepends+=('python-bootstrap')
-depends=(${depends[@]//python-jaraco.functools/})
-depends=(${depends[@]//python-jaraco.context/})
-depends=(${depends[@]//python-jaraco.context/})
-depends=(${depends[@]//python-autocommand/})
-depends=(${depends[@]//python-inflect/})
-unset checkdepends
-unset check
-eval "$(
- declare -f build | \
- sed '
- s/python -m build -wn/python -m build -wn -x/g
- '
-)"
diff --git a/extra/python-jaraco.functools/PKGBUILD b/extra/python-jaraco.functools/PKGBUILD
deleted file mode 100644
index d95ca919..00000000
--- a/extra/python-jaraco.functools/PKGBUILD
+++ /dev/null
@@ -1,13 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-wheel/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
-eval "$(
- declare -f build | \
- sed '
- s/python -m build --wheel --no-isolation/python -m build --wheel --no-isolation -x/g
- '
-)"
diff --git a/extra/python-jaraco.text/PKGBUILD b/extra/python-jaraco.text/PKGBUILD
deleted file mode 100644
index 29e02c8a..00000000
--- a/extra/python-jaraco.text/PKGBUILD
+++ /dev/null
@@ -1,18 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-wheel/})
-makedepends+=('python-bootstrap')
-depends=(${depends[@]//python-jaraco.functools/})
-depends=(${depends[@]//python-jaraco.context/})
-depends=(${depends[@]//python-jaraco.context/})
-depends=(${depends[@]//python-autocommand/})
-depends=(${depends[@]//python-inflect/})
-unset checkdepends
-unset check
-eval "$(
- declare -f build | \
- sed '
- s/python -m build --wheel --no-isolation/python -m build --wheel --no-isolation -x/g
- '
-)"
diff --git a/extra/python-more-itertools/PKGBUILD b/extra/python-more-itertools/PKGBUILD
deleted file mode 100644
index 94928e1c..00000000
--- a/extra/python-more-itertools/PKGBUILD
+++ /dev/null
@@ -1,8 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-wheel/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-ordered-set/PKGBUILD b/extra/python-ordered-set/PKGBUILD
deleted file mode 100644
index 5c46bfcf..00000000
--- a/extra/python-ordered-set/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-packaging/PKGBUILD b/extra/python-packaging/PKGBUILD
deleted file mode 100644
index 5c46bfcf..00000000
--- a/extra/python-packaging/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-pefile/PKGBUILD b/extra/python-pefile/PKGBUILD
deleted file mode 100644
index 87022320..00000000
--- a/extra/python-pefile/PKGBUILD
+++ /dev/null
@@ -1,2 +0,0 @@
-# bootstrapping
-makedepends=('python-bootstrap')
diff --git a/extra/python-pyproject-hooks/PKGBUILD b/extra/python-pyproject-hooks/PKGBUILD
deleted file mode 100644
index 13a5299b..00000000
--- a/extra/python-pyproject-hooks/PKGBUILD
+++ /dev/null
@@ -1,8 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-wheel/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-setuptools-scm/PKGBUILD b/extra/python-setuptools-scm/PKGBUILD
deleted file mode 100644
index 5057a55f..00000000
--- a/extra/python-setuptools-scm/PKGBUILD
+++ /dev/null
@@ -1,9 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-wheel/})
-makedepends+=('python-bootstrap')
-depends=(${depends[@]//python-packaging/})
-depends=(${depends[@]//python-setuptools/})
-unset checkdepends
-unset check
diff --git a/extra/python-tomli/PKGBUILD b/extra/python-tomli/PKGBUILD
deleted file mode 100644
index e8287d26..00000000
--- a/extra/python-tomli/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-installer/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check
diff --git a/extra/python-wheel/PKGBUILD b/extra/python-wheel/PKGBUILD
deleted file mode 100644
index bf6e3996..00000000
--- a/extra/python-wheel/PKGBUILD
+++ /dev/null
@@ -1,9 +0,0 @@
-# temporary to build python-build with python-bootstrap (breaking cycles)
-depends=(${depends[@]//python-packaging/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends=(${makedepends[@]//python-setuptools/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-installer/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check