Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/ruby-minitest/PKGBUILD12
-rw-r--r--community/ruby-open-uri/PKGBUILD1
2 files changed, 13 insertions, 0 deletions
diff --git a/community/ruby-minitest/PKGBUILD b/community/ruby-minitest/PKGBUILD
new file mode 100644
index 00000000..f41379db
--- /dev/null
+++ b/community/ruby-minitest/PKGBUILD
@@ -0,0 +1,12 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+
diff --git a/community/ruby-open-uri/PKGBUILD b/community/ruby-open-uri/PKGBUILD
index 2a7c58f7..75884198 100644
--- a/community/ruby-open-uri/PKGBUILD
+++ b/community/ruby-open-uri/PKGBUILD
@@ -9,3 +9,4 @@ eval "$(
'
)"
+unset check