Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/python-cryptography/PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/extra/python-cryptography/PKGBUILD b/extra/python-cryptography/PKGBUILD
index c42f0881..2b934dbc 100644
--- a/extra/python-cryptography/PKGBUILD
+++ b/extra/python-cryptography/PKGBUILD
@@ -1,3 +1,9 @@
source+=('skip-aead-tests-on-32-bit.patch')
sha512sums+=('SKIP')
-eval "$(declare -f prepare | sed 's@cd cryptography@cd cryptography; patch -p1 -i ../skip-aead-tests-on-32-bit.patch@')"
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd cryptography\n}\n'
+ } \
+ | sed 's@cd cryptography@cd cryptography; patch -p1 -i ../skip-aead-tests-on-32-bit.patch@'
+)"