Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--blacklist/pentium4/deno1
-rw-r--r--blacklist/pentium4/electron/electron331
-rw-r--r--blacklist/pentium4/python-onnx/python-onnx (renamed from blacklist/pentium4/python-onnx)0
-rw-r--r--blacklist/pentium4/python-onnx/python-onnxruntime (renamed from blacklist/pentium4/python-onnxruntime)0
-rw-r--r--blacklist/pentium4/python-onnx/python-onnxruntime-opt (renamed from blacklist/pentium4/python-onnxruntime-opt)0
-rw-r--r--blacklist/pentium4/python-onnx/python-onnxruntime-opt-rocm (renamed from blacklist/pentium4/python-onnxruntime-opt-rocm)0
-rw-r--r--core/archlinux32-keyring/PKGBUILD4
-rw-r--r--extra/libpgm/PKGBUILD4
-rw-r--r--extra/libwpe/PKGBUILD21
-rw-r--r--extra/openmpi4/PKGBUILD1
10 files changed, 30 insertions, 2 deletions
diff --git a/blacklist/pentium4/deno b/blacklist/pentium4/deno
new file mode 100644
index 00000000..cd11b2ed
--- /dev/null
+++ b/blacklist/pentium4/deno
@@ -0,0 +1 @@
+doesn't build
diff --git a/blacklist/pentium4/electron/electron33 b/blacklist/pentium4/electron/electron33
new file mode 100644
index 00000000..78bf1a60
--- /dev/null
+++ b/blacklist/pentium4/electron/electron33
@@ -0,0 +1 @@
+see above
diff --git a/blacklist/pentium4/python-onnx b/blacklist/pentium4/python-onnx/python-onnx
index 8fd76560..8fd76560 100644
--- a/blacklist/pentium4/python-onnx
+++ b/blacklist/pentium4/python-onnx/python-onnx
diff --git a/blacklist/pentium4/python-onnxruntime b/blacklist/pentium4/python-onnx/python-onnxruntime
index fc41a4cd..fc41a4cd 100644
--- a/blacklist/pentium4/python-onnxruntime
+++ b/blacklist/pentium4/python-onnx/python-onnxruntime
diff --git a/blacklist/pentium4/python-onnxruntime-opt b/blacklist/pentium4/python-onnx/python-onnxruntime-opt
index fc41a4cd..fc41a4cd 100644
--- a/blacklist/pentium4/python-onnxruntime-opt
+++ b/blacklist/pentium4/python-onnx/python-onnxruntime-opt
diff --git a/blacklist/pentium4/python-onnxruntime-opt-rocm b/blacklist/pentium4/python-onnx/python-onnxruntime-opt-rocm
index fc41a4cd..fc41a4cd 100644
--- a/blacklist/pentium4/python-onnxruntime-opt-rocm
+++ b/blacklist/pentium4/python-onnx/python-onnxruntime-opt-rocm
diff --git a/core/archlinux32-keyring/PKGBUILD b/core/archlinux32-keyring/PKGBUILD
index 1a1d861b..840a79e6 100644
--- a/core/archlinux32-keyring/PKGBUILD
+++ b/core/archlinux32-keyring/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Erich Eckner <deep42thought@archlinux32.org>
pkgname=archlinux32-keyring
-pkgver='20240131'
+pkgver='20240924'
pkgrel='1'
pkgdesc='Arch Linux 32 PGP keyring'
arch=('any')
@@ -10,7 +10,7 @@ install="${pkgname}.install"
conflicts=('archlinux32-keyring-transition')
replaces=('archlinux32-keyring-transition')
source=("https://sources.archlinux32.org/sources/${pkgname}-v${pkgver}.tar.gz"{,.sig})
-sha512sums=('a1b16e4cf43b5f5cfea2184d55c1d19ccd6398d224a09c36bbd29d36a6685eb8a1'
+sha512sums=('a1b16e4cf43b5f5cfea2184d55c1d19ccd6398d224a09c36bbd29d36a6685eb8a18035c76b33b6363850cfb7243d484f537c661c8f3a6bbfb68ab1bbeb8a94a9'
'SKIP')
validpgpkeys=('33CA3597B0D161AAE4173F65C17F1214114574A4') # obtain from https://archlinux32.org/keys.php
diff --git a/extra/libpgm/PKGBUILD b/extra/libpgm/PKGBUILD
index af490aa7..dbb0fa1d 100644
--- a/extra/libpgm/PKGBUILD
+++ b/extra/libpgm/PKGBUILD
@@ -2,3 +2,7 @@
# checksum.c:952:34: warning: implicit declaration of function '_mm_cvtm64_si64'; did you mean '_mm_cvtsi64_si32'? [-Wimplicit-function-declaration]
makedepends+=('clang')
eval "$(declare -f build | sed 's@./configure@CC=clang ./configure@')"
+
+if [ "$CARCH" = 'i486' ]; then
+ makedepends+=(llvm14-libs)
+fi
diff --git a/extra/libwpe/PKGBUILD b/extra/libwpe/PKGBUILD
index 1623a33f..daa08457 100644
--- a/extra/libwpe/PKGBUILD
+++ b/extra/libwpe/PKGBUILD
@@ -2,3 +2,24 @@
if [ "$CARCH" = 'i486' ]; then
makedepends+=(libglvnd)
fi
+
+# no available currently
+makedepends=(${makedepends[@]//hotdoc/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/-D build-docs=true//g
+ '
+)"
+eval "$(
+ declare -f package_libwpe | \
+ sed '
+ /doc/d
+ '
+)"
+eval "$(
+ declare -f package_libwpe-docs | \
+ sed '
+ /mv doc/d
+ '
+)"
diff --git a/extra/openmpi4/PKGBUILD b/extra/openmpi4/PKGBUILD
index 1135db5e..295cc9a6 100644
--- a/extra/openmpi4/PKGBUILD
+++ b/extra/openmpi4/PKGBUILD
@@ -112,3 +112,4 @@ eval "$(
# new tests break happilly on 32-bit and with newer gccs
unset check
unset checkdepends
+