Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-09-09 10:52:07 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-09-09 10:52:07 +0200
commitc027ec7d1a8f9d024a8cca4d4a98980e829e2506 (patch)
tree04a1b84ef30877b6b8727d0df5345fc2dbef3fb4 /extra
parent9633f2a261dd0d8013b41b9eaedfecc898519a62 (diff)
extra/dump_syms: fix target in cargo fetch
Diffstat (limited to 'extra')
-rw-r--r--extra/dump_syms/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/extra/dump_syms/PKGBUILD b/extra/dump_syms/PKGBUILD
new file mode 100644
index 00000000..a40db396
--- /dev/null
+++ b/extra/dump_syms/PKGBUILD
@@ -0,0 +1,8 @@
+# use proper architecture for cargo fetching prebuilt binaries
+# (why can't we build them here from source?!)
+eval "$(
+ declare -f prepare | \
+ sed '
+ s|x86_64-unknown-linux-gnu|i686-unknown-linux-gnu|g
+ '
+)"