Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-08-13 11:15:56 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-08-13 11:15:56 +0200
commit790dd4e48b62f3075381c2d45ece814a21207325 (patch)
treeaecd94f4d98262a49516ed8d3f734bb81fa505f9 /extra
parent8702b06abbef15280b869cada0e9d1a75f50513b (diff)
extra/babl: fixed SIMD flags for meson
Diffstat (limited to 'extra')
-rw-r--r--extra/babl/PKGBUILD30
1 files changed, 28 insertions, 2 deletions
diff --git a/extra/babl/PKGBUILD b/extra/babl/PKGBUILD
index 697d5662..f7ae127c 100644
--- a/extra/babl/PKGBUILD
+++ b/extra/babl/PKGBUILD
@@ -1,12 +1,38 @@
+# disable SSE4, AVX2, f16c on 486, 686, pentium4
+eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Denable-sse4_1=false -Denable=avx2=false -Denable-f16c=false /g
+ '
+)"
+
# disable SSE2 on 486 and 686
-if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
eval "$(
declare -f build | \
sed '
- s/configure/configure --disable-sse2/
+ s/arch-meson /arch-meson -Denable-sse2=false /g
+ '
+ )"
+fi
+
+# disable all SIMD optimizations on 486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Denable-sse=false /g
'
)"
fi
# workaround for FS#71143
makedepends+=(openssh)
+
+# documentation build fails
+eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Dwith-docs=false /g
+ '
+)"