Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-07-07 10:24:33 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-07-07 10:24:33 +0200
commit4e5b06a20ec335846c1b9fffe4610057cbcfc496 (patch)
treefdb22558524e21271a04177122d640f13e899eab /extra
parent8fd23797888a9b7e9d13230b442e606f28ec2f95 (diff)
extra/python-installer: new trial to bootstrap
Diffstat (limited to 'extra')
-rw-r--r--extra/python-installer/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/extra/python-installer/PKGBUILD b/extra/python-installer/PKGBUILD
index e5c1ec0f..b67bf28e 100644
--- a/extra/python-installer/PKGBUILD
+++ b/extra/python-installer/PKGBUILD
@@ -1,8 +1,12 @@
-# breaking the cycle with python-spinx
-makedepends=(${makedepends[@]//python-sphinx-furo})
-makedepends=(${makedepends[@]//python-sphinx-argparse})
-makedepends=(${makedepends[@]//python-sphinx})
-makedepends=(${makedepends[@]//python-myst-parser/})
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
eval "$(
declare -f build | \
sed '
@@ -13,3 +17,4 @@ eval "$(
/docs\/build\/html/d
'
)"
+